Honeywell ST9400C central heating programmer fault problem fixed

About 2 years ago we had our central heating boiler replaced and a new Honeywell ST9400C programmer was installed with the new boiler. This worked fine for about a year and then we found that although the radiator circuit came on via the timer, the water heating (to the hot water cylinder) did not. The green LEDs came on for both circuits however. I found I could still press Extra Hour on the h/w side and it would then heat the hot water. It just didn’t want to operate hot water and space heating together.

I was busy with other jobs and did not feel confident about getting a heating engineer in, so I just used the Extra Hour button work-around. I bled the system of air & re-pressurised it; this made no difference. I wondered if some sort of fluidix effect was in play where the water decided to go round one circuit & kept going on that one circuit.

Summer came & the hot-water worked fine on the timer, with no space heating necessary. When that stopped working I checked out the ST9400C. It was 2 years since installation.

I found this is a Atmega 3290V microprocessor based controller. It has two 48V DC relays which provide switching to switch the mains Line out to “OFF” or “ON” outputs (presumably for controlling open/shut on zone valves). One pair of outputs is for the h/w circuit, the other for radiator space heating.

I discovered that when one circuit was on, the relevant relay only received 21V DC, well short of 48V. With both circuits on, there was only 16.5V. Presumably the available power had been reducing over time so that at first there was only enough to trip one relay and then eventually neither relay would switch.

There were two aluminium-can electrolytic capacitors near the diode bridge & I replaced these with capacitors rated 63V. This did not fix the problem. I tested the big blue mains series film-type capacitor. It did not seem to leak, measured with a DVM & it measured 0.1uF on a bridge. I was puzzled. I did not understand the markings on this capacitor so I did some internet research. I discovered the capacitor should be 0.68 uF. So perhaps it was leaking and failing under mains voltage?

I replaced this capacitor with a similar 0.68 uF item, but with a higher voltage rating & re-tested the ST9400C. The voltage to the relays was well up, better than doubled and they switched over fine. So that problem was fixed!

The previous boiler & mechanical clock controller had worked fine for 30 years. That did not contain any capacitors though. The fancy Honeywell controller lasted a year before going faulty. Maybe the capacitor was poor quality?

Older, simpler, AC devices are being replaced with more complex devices which have chips & processors requiring DC supply and so more components. The processors run software.

An aeroplane now is a computer network which happens to fly.

This is all fine if the additional risks of complexity are off-set by sound design & maintenance so that stuff works. The risks may increase with the internet of things. I hope I don’t get to the stage where the car won’t start because the fridge is having a network flame war with the toaster!

Douglas Adams foresaw this sort of situation years ago when the spaceship Heart Of Gold was distracted from defending against a missile attack because Arthur Dent had requested a real cup of tea from the vending machine. He was ahead of his time, that man.